This project has moved and is read-only. For the latest updates, please go here.
2
Vote

compatibility with 1.10.1

description

On a freshly downloaded 1.10.1 I get following error when installing a freshly downloaded Vandelay.industries nuget package I get following error:

An exception of type 'Orchard.OrchardCoreException' occurred in Orchard.Framework.dll but was not handled in user code

Additional information: Error compiling module "Vandelay.Industries" from file "/OrchardLocal/Modules/Vandelay.Industries/Vandelay.Industries.csproj":
Assembly reference 'System.Data.DataSetExtensions' for project '/OrchardLocal/Modules/Vandelay.Industries/Vandelay.Industries.csproj' cannot be loaded

To overcome this issue I added - based on the discussion around Orchard issue #6406 - to the Vandelay.industries Web.config AND
changed the target Framework to 4.5.2 plus the appr. changes in .csproj:
<!-- added due to #6406 -->
          <add assembly="System.Data.DataSetExtensions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
          <add assembly="System.Web.Entity, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
          <add assembly="System.Transactions, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" />
PS: I don't know whether these are the correct changes!? In fact I found some similar errors with BingMaps!

doesn't the Vandelay.Industries (1.8) need some changes to run in 1.10.1?
thanks for your time and advise, ed

comments

GioviQ wrote Aug 24, 2016 at 10:30 PM

I am trying theme picker, but admin menu item does not appear.

GioviQ wrote Aug 24, 2016 at 11:44 PM

I restore the database and now I see the tabs in theme admin page.