This project has moved and is read-only. For the latest updates, please go here.

Orchard 1.8 CMS Meta Description and keyword (Vandelay Module 1.8) Installation Error

Oct 8, 2014 at 8:43 PM
Edited Oct 8, 2014 at 9:51 PM
I am using Orchard 1.8 and I installed the "Vandelay Industries - Version: 1.8" module from the Gallery onto my development box (running an VS Orchard project) and enabled just the "Vandelay Meta" (it's all I need at the moment). I added the "Meta" part to the "Page" content type and all that worked fine. I as able to add both a "Description" and "Keywords" to pages.

When I did the module installation to my production server (our server) which is the same version of Orchard (it was set up from the dev copy a month or so ago), I am getting a message "Some features need to be upgraded: Vandelay.Industries" at the top of the Admin "Modules" - "Features" screen and there is a red box around the "Vandelay Meta" feature and there is also a "Upgrade" link next to the feature's "Disable" link. If I click it the page just refreshes and nothing changes.

The part is also not available for adding to the page content type.

The is also an error in the Orchard Log

2014-10-08 14:10:58,385 [13] Orchard.Exceptions.DefaultExceptionPolicy - Default - An unexpected exception was caught ...servername/Packaging/PackagingServices/InstallPackageDetails?packageId=Orchard.Module.Vandelay.Industries&version=1.8&sourceId=1&redirectUrl=%2FPackaging%2FGallery%2FModules Orchard.OrchardCoreException: Unable to make room for file "C:\inetpub\A1_Website-OrchardCMS\App_Data\RecipeQueue\38a6aedb4c514ea1866be2138d14c99e\0" in "App_Data" folder ---> System.UnauthorizedAccessException: Access to the path 'C:\inetpub\A1_Website-OrchardCMS\App_Data\RecipeQueue\38a6aedb4c514ea1866be2138d14c99e\0' is denied.

The App_Data and it's child folders has Read Execute Write permission IIS 7 IIS_IUSRS account

There are also some errors "CREATE TABLE permission denied in database " i.e.

2014-10-08 14:12:19,332 [7] Orchard.Data.Migration.DataMigrationManager - Default - Error while running migration version 0 for Vandelay.Industries
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Data.SqlClient.SqlException: CREATE TABLE permission denied in database 'Orchard_ProductionDB'.
at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action1 wrapCloseInAction)
at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection, Action
1 wrapCloseInAction)
at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose)
at System.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj, Boolean& dataReady)
at System.Data.SqlClient.SqlCommand.RunExecuteNonQueryTds(String methodName, Boolean async, Int32 timeout, Boolean asyncWrite)
at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(TaskCompletionSource1 completion, String methodName, Boolean sendToPipe, Int32 timeout, Boolean asyncWrite)
at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
at Orchard.Data.Migration.Interpreters.DefaultDataMigrationInterpreter.RunPendingStatements()
at Orchard.Data.Migration.Interpreters.DefaultDataMigrationInterpreter.Visit(CreateTableCommand command)
at Orchard.Data.Migration.Interpreters.AbstractDataMigrationInterpreter.Visit(ISchemaBuilderCommand command)
at Orchard.Data.Migration.Schema.SchemaBuilder.CreateTable(String name, Action
1 table)
at Vandelay.Industries.MetaMigrations.Create()
--- End of inner exception stack trace ---
at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
at System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
at Orchard.Data.Migration.DataMigrationManager.Update(String feature)

And the "Vandelay_Industries_MetaRecord" "Vandelay_Industries_SettingsRecord" are not in the production database (they are in the dev DB)

I have tried reinstalling the module and it does not fix it.

Any way to fix this? If so how?

Thanks in advance,

Oct 9, 2014 at 2:26 PM
It seems to have been a permission issue the "db_ddladmin" role needed to be added to the login that the site uses to access the production database. Then the "Upgrade" link did correct the error and the "Meta" part was available to be added to the page content type.